Are you a high school teacher? We have a special message for you!

QuickStart

Just wondering what the 2.6 version requires to run harmonia quickstart? I have the most current of each browser and it still asks to upgrade my technology.